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Communication between the Pulse Front-end and the PC 

Configuring Pulse IP Addresses 

The Pulse Front-end communicates with the PC using an Ethernet connection. The 
communication protocol used is the same as that used to connect your PC to a 
network. In fact, it is possible to connect multiple Pulse units to a single PC using an 
Ethernet hub or to set up communication with the Pulse Front-end over a standard 
network, though this will not be discussed here. 
Before the PC can communicate with the Front-end, the PC that the system is to be 
connected to must know what IP address that the Pulse Front-end is using. It may turn 
out that the PC was last connected to the Pulse Front-end that you wish to use. In this 
case this process can be skipped.  
The following steps describe the process of setting up the PC to communicate with the 
Pulse Front-end using the 'Pulse Front-end Setup' Program. 
 

1.  Load 'Pulse Front-end Setup' Program. 
 

 
 

2. Each Pulse system has a label specifying the IP Address or a name for the 
Pulse Front-end that should be used with this system. Either look for this IP 
Address or this name in the 'Existing configurations' box and select it. In this 
case the IP address for this Pulse Front-end is 10.10.10.12, this has been 
selected. When this has been selected, press the 'Connect' button. 
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3. The next screen lets you start a Front-end configuration check. Run this check 
by pressing the 'Next' button. 

 

 
 

4. The next screen tells you that you have been successful in setting up 
communication between the Pulse Front-end and the PC. Click finish and exit 
the program. The equipment is now ready to start taking measurements. 
This procedure has to be done after every time the PC is switched off even if 
the Pulse Front-End was not unplugged from the PC. 

 

 

If it wasn't quite that easy… 

There are a number of things that can go wrong setting up communication between 
the Pulse Front-end and the PC. The following gives a quick guide to solving these 
problems. 
 

• The PC may not be configured with a valid IP Address to communicate with 
the Front-end successfully. Try setting the IP address on the PC as following 
using the control panel and network connection. (Details are not given here on 
how to do this as it varies with Operating System.) 

o IP Address : 10.10.10.50 
o Subnet Mask : 255.255.0.0 
o Preferred DNS : 172.36.0.250 
o Other values are not important. 
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• The IP address or name of the Pulse Front-end may not match the IP address 
stored in the Front-end. It is possible to change this IP address using the 'Pulse 
Front-end Setup' Program and an RS-232 connection. Detail of how to do this 
are not given here as this should not have to be performed regularly, nor by the 
in-experienced user. 

• A cross-over Ethernet cable must be used, unless a network hub is in use. 
 

Basic measurements 

 
Although, Pulse comes with numerous built-in setups for measuring various 
situations, for example Modal Test Consultant is a powerful template performing 
modal analysis, it is important to understand how to setup these templates, so that the 
user can understand how to modify these pre-set configuration if necessary, or how to 
setup templates that are not provided. 
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Time Signal and Spectrum Analysis 
 
The most basic Sound and Vibration measurements that can be made are Time Signal 
and Spectrum analysis. The following section gives instructions on how to setup a 
simple measurement of the vibrations associated with tapping a beam. 

Equipment Setup 

 
The following equipment is required for this demonstration. 
 

1x Pulse Front-end. 
1x Pulse Front-end power supply. 
1x PC with Pulse Labshop installed. 
1x Ethernet crossover 
1x Pulse Dongle. 
1x B&K 2635 Charge Amplifier. 
1x B&K 4393 Accelerometer. 

 
This equipment should be connected as shown below. 

 

Computer with Pulse 

Labshop installed.
Cross-over Ethernet cable

Pulse Dongle

Pulse Front-end

Charge Amplifier

Accelerometer

BNC Cable between

Charge Amplifier and 

Channel 1 on the

Pulse Front-end

Micro-dot cable between

accelerometer and

charge amplifier.

Computer with Pulse 

Labshop installed.
Cross-over Ethernet cable

Pulse Dongle

Pulse Front-end

Charge Amplifier

Accelerometer

BNC Cable between

Charge Amplifier and 

Channel 1 on the

Pulse Front-end

Micro-dot cable between

accelerometer and

charge amplifier.

 
 
The accelerometer can be attached to anything that the vibration spectrum or time 
response can be measured. A simple setup may involve mounting an accelerometer to 
a table and the response of the tapping the table can be measured. 
The results given in this document have been measured using a suspended beam. 

 

 

 
It is possible to substitute another type of 
Charge Amplifier and/or accelerometer if 
these are not available. 
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Setting up the template in Labshop 

 
The following describes how to setup a Pulse Labshop template to measure the time 
signal and spectrum response of an accelerometer mounted on a beam that is tapped 
with a finger. 
 

1. Load the 'Pulse Labshop' program. 
 

 
 

2. Create a blank project by selecting 'Create blank project' and then clicking 
'Ok'. 
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3. In order to setup a template, there are four important windows. These are 
opened by selecting 'Organizer' from the menu and then clicking on each of 
the four window titles listed below. 

 

 
 

• Configuration 
This window contains details of the inputs and outputs on the 
Pulse Front-end and to specify what instruments are connected 
to this Front-end. 

• Measurement 
This window is used to setup signal grouping and to specify 
which analysers are to be used. 

• Function 
This window is used to setup the outputs from the analysers and 
how they are to be used. 

• Display 
This window shows which measurements are currently 
displayed and allows modifications to be made to the way the 
measurements are displayed. 

 
4. The four windows mentioned previously are very important for setting up the 

Pulse Labshop template. It is important that they are easily accessible. It is 
therefore recommended that these windows be setup as shown below. This 
configuration follows the flow that the setup process uses. 
i.e. Configuration → Measurement → Function → Display 
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5. When creating a new blank template, Pulse Labshop automatically sets up 
signals and attaches then to each of the Front-end inputs. In this case, only one 
input is going to be used. Therefore, all the signals that have setup by Pulse 
need to be removed. This is done by selecting Configuration → Remove → 
All Signals. This step can be thought of as resetting the Front-end ready for a 
new program. 

 

 
 

6. The next step is to expand the information in the configuration organizer. This 
is done by clicking on the  icons. This window shows all the all the input and 
outputs that are available on the Pulse Front-end. The Pulse Front-end consists 
of two basic components. Firstly, there is the Pulse Frame, this is the black 
box that contains the electronics, and these frames come in various different 
sizes. Different electronic modules are connected into the Pulse Frame during 
manufacture. These modules contain the various acquisition hardware 
modules. 
The LAN Interface Module Type 7533 is common to most Pulse Front-ends. 
This is the unit that allows communication between the PC and the Pulse 
Front-end. This module also contains a number of low speed inputs that 
sample at 10 Hz. Generally, these inputs are not used. It is also possible to get 
LAN Interface Modules that include input and output hardware. 
The other input module/s can be used for data acquisition and signal 
generation. These modules come in various different configurations. 
As the inputs on the LAN Interface module are not going to be used close 
them by selecting clicking on the  icon. 
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7. In order for measurements to be made with Pulse, a transducer has to be 
connected to one of the inputs shown in the configuration organiser. This is 
done by right clicking on the input that the transducer will be connected to and 
then selecting 'Select Transducer'. 

 

 
 

8. This brings up the 'Database Administrator' window. Using this window, it is 
possible to attach many different types of transducers to the input. In this case 
an accelerometer is going to be used for the measurement. This is selected 
under family. 

 

 
 
 
 

LAN INTERFACE 
MODEL TYPE 7533 

INPUT/OUTPUT 
MODULE 
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9. The next step is to select the name of the transducer that is to be used. In this 
case a Type-4393 Accelerometer is to be used, with this connected to a Type-
2635 Charge Amplifier. The 4393+2635 configuration should be available 
under type, select this. If it is not available, you will have to either setup this 
configuration using the section in this guide, 'Setting up Transducers', or 
modify the setting of an existing transducer for this setup. 

 

 
 

10. Now that the transducer is connected in the software, a signal needs to be 
allocated to this transducer. This is done by right clicking on the transducer 
and selecting 'Add Signal'. 

 

 
 

11. This signal can be given a name by right clicking on it and selecting 'Edit 
Label'. The name in this case should be 'Accelerometer', but any name can be 
used. 
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12. The 'Configuration Organizer' window should now look as shown below. 
 

 
 

13. To make the changes that have been made to the 'Configuration Organiser' 
applicable to other windows it is necessary to click the 'Activate Template' 
button or press F2. 
This button is used to apply many changes that can be made to this and other 
windows. If changes are made to the template, but they don't appear to have 
taken effect, use this button to update all of the information in the template. 

 

 
 

14. For the moment, work in the 'Configuration Organizer' window is complete. 
The next steps involve using the 'Measurement Organizer' window. The list in 
the 'Measurement Organizer' should be expanded by clicking on the  or by 
right clicking the text 'Measurement Organizer' and selecting 'Expand all'. 
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15. It is now required to setup signal groups. Signal groups are required because 
they the analysers that will be used shortly to accept multiple signals. It is only 
possible to feed a signal into a Pulse Analyser by grouping it first. This step 
may seem a bit pointless when there is only one signal, but the need for this 
step will become clear when multiple signals are being used. 
In this case, right click 'Groups' and select 'New Group'. 

 

 
 

16. It is possible to rename this signal group by right clicking the group and 
selecting 'Edit Label'. 

 
 

17. Any name can be used for this group, but in this case the name 'Accelerometer 
Group' is suggested. 

 

 
 

18. Now a signal must be added to this signal group. This is done by right clicking 
the signal group label and selecting 'Insert Signal' → 'Accelerometer'. 
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19. The type of analyser that will be used needs to be set. In this case, the time 
domain and frequency spectrum of the signal is required. An 'FFT Analyser' is 
appropriate for this type of analysis. 
To insert this type of analyser into this template, right click on 'Setup', then 
select 'Insert' → 'FFT Analyser'. 

 

 
 

20. This analyser now needs to be told which signals to analyses. This is done by 
connecting this analyser to 'Accelerometer Group'. To do this right click 'FFT 
Analyser' and select 'Insert Group' → 'Accelerometer Group'. 

 

 
 

21. Quite a few changes have been made since the template has been updated. 
Click the 'Activate Template' button now, or press 'F2' to carry the changes 
that have been made over to the 'Input' section of the 'Measurement Organiser'. 

 

 
 

22. The details of the 'FFT Analyser' and input signal are now in the available in 
the 'Input' section. Remember to click the 'Activate Template' button regularly 
so that changes are updated throughout the template. 
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23. Now the 'FFT Analyser' needs to be set up. This process is started by right 
clicking 'Setup' and selecting properties. 

 

 
 

24. A number of different controls are available here controlling how the 
measurement are taken and stored. For this demonstration on the trigger will 
be used. 
A trigger is some condition that has to be satisfied before a measurement will 
be taken. In this case the trigger will be when the signal or acceleration 
exceeds a certain level. This way the measurement will only be taken when 
after the beam has been tapped. 
To do this, enter a new trigger name, in this case 'Trigger 1' and click the 
'New' button. 
 

 
 

25. Now change the 'Trigger Type' to 'Signal'. 
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26. The easiest way to set the trigger level is to click the 'Graphical Setup' button. 
 

 
 

27. This program takes a measurement and then allows the trigger levels to be set 
based on this measurement. Click the 'Start' button and then tap the beam with 
a small amount of force. 
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28. The response of this beam to this tap is shown on the graph. Now set the 
trigger level such that the initial response exceeds this level. The trigger level 
is shown on the graph as the green line. The trigger level can be adjusted by 
either entering a value in the green box, 'Level', or graphically moving it with 
the mouse. 
The blue line or 'Hysteresis' level indicates the amount that the signal level 
must change by after the trigger is activated for that trigger to still be valid. A 
very large 'Hysteresis' level may mean that it is very difficult to activate the 
trigger. 
When the trigger level is correctly set, press 'Ok'. 

 

 
 

29. From the previous graph in the trigger window, it can be seen that by the time 
that the trigger is activated, some of the initial parts of the signal have been 
lost. It is therefore necessary to take the measurement on some of the data 
before the trigger is activated. This is done by putting a negative value into the 
delay field. In this case a delay of -½ a second is used. Note that this value is 
automatically changes to 500 milliseconds by Pulse Labshop. 
Click the � button in the top left hand corner of the 'Setup' window to close it. 
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30. Now that the trigger has been configured, it is now necessary to configure the 
FFT analyser. Right click 'FFT Analyser' and select properties. This brings up 
the configuration for the FFT Analyser. Using this window it is possible to 
control a number of aspects of the FFT Analyser, including the resolution or 
number of lines used by the analysis, the frequency span of the analysis, type 
of averaging used and triggers can be applied. 
The analysis that will be used here will only look at frequencies up to 1.6 kHz. 
Set the frequency span to 1.6 kHz and also select 1600 lines so that the 
measurement resolution will be 1 Hz. 

 

 
 
31. Click on the 'Trigger' tab to bring up the trigger tab for the 'FFT Analyser'. The 

trigger defined previously was called 'Trigger 1'. Set both 'Start Trigger' and 
'Record Trigger' to 'Trigger 1'. 
Close this window by clicking on the � button in the top right hand corner. 
The FFT Analyser is now set up. Click 'Activate Template' or press F2 to 
make sure the changes are applied to the template. 

 

 
 

32. It is now time to move across to the 'Function Organiser' window. This 
window is used to control which measurements are to be recorder by the 
analysers. Expand 'Function Organiser' and right click 'Function Group'.  
Select 'Insert'. This will add a new measurement. 
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33. Pulse Labshop inserts a default measurement based on previous setting for the 
template. In this case, a time response is required, so right click the created 
function and select properties, so that the function can be changed to a time 
response. 

 

 
34. This brings up the functions property window. Change the function from 'Auto 

spectrum' to 'Time'. 
 

 
 
 

35. Insert another function, as per the previous instructions. Again right click the 
function and change the Function type to 'Auto spectrum'. 

 

 
 

36. A plot of the resulting measurement is easily taken by again clicking on each 
of the created functions and selecting 'Show as' → 'Classic Display'. Do this 
for both the 'Time' and 'Auto spectrum' functions. 
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37. There should now be two windows that will display the results of the time and 

Autospectrum measurements. This means that there are now six windows open 
and switching between these windows could be confusing. It is possible to set 
up task displays so that it is easy to switch between different parts of the 
template. 

 

 
 

38. Turn on the task bar by selecting 'View' → 'Task Bar'. 
 

 
 

39. This will open the task bar on the left hand side of the screen. Right click on 
this task bar and select 'Add Task'. 
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40. Name the task display that you are creating. The first one that will be created 
here will be to display the configuration windows. Type 'Configuration' and 
press the 'Ok' button. 

 

 
 

41. This will create a 'Configuration' button. The icon for this button can be 
changed by right clicking the button and selecting 'Change Icon'. Click the 
configuration button so that it is highlighted as shown below. 

 

 
 

42. Organise the windows so that you can see all of the four configuration 
windows and then select 'Task' → 'Save Task Layout'. This saves this display 
to the configuration button, now when ever this button is pressed these four 
windows will come up. Before trying this out, firstly set up another task button 
that will display the time and Autospectrum plots. 
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43. Right click the Task Bar again and select 'Add Task'. Name this new task 
'Display'. 

 

 
 

44. Now bring up the two results windows. Use the 'Window' menu to bring 
'Time' and 'Autospectrum' to the front windows. 

 

 
 

45. Rearrange these windows so that both results will be clearly visible. Select the 
'Display' task button and then select 'Task' → 'Save Task Layout' from the 
menu. 

 

 
 

 
46. Try switching between the windows by clicking on the task buttons. 
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47. The 'Measurement Bar' toolbar has been disabled for the 'Display' task. Click 
the 'Display' task to activate this window. The 'Measurement Bar' toolbar 
contains the 'Activate Template' button and also the buttons that are used to 
start and stop the measurements. Reactivate this toolbar by selecting 'View' → 
'Toolbars' → 'Measurement Bar'. Then select 'Task' → 'Save Task Layout' to 
ensure that the toolbar is displayed each time the 'Display' window is opened. 

 

 
 
 

48. It is now possible to start taking measurements. Click the 'Start' button on the 
'Measurement Bar' toolbar. 
The measurement process will not start until the trigger conditions have been 
met. Therefore, tap the beam to start the measurement process. 
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49. The display will take a couple of seconds to display the response. The time 
and Autospectrum response should then be displayed in their respective 
windows. The graphs may need to be scaled, if so right click on the graph and 
select properties. Under the Y Axis tab click Autoscale. Alternately the use of 
the shortcut keys F10, Ctrl+F10 or Alt+F10 for the different autoscaling 
options. 

 

 
 

50. It is possible to save the template by selecting 'File' → 'Save' from the menu. 
Similarly, in the future this template can be opened using 'File' → 'Open'. 
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Frequency Response Functions 

Equipment Set-Up 

The following equipment is required for this demonstration. 
 

1x Pulse Front-end. 
1x Pulse Front-end power supply. 
1x PC with Pulse Labshop installed. 
1x Ethernet crossover 
1x Pulse Dongle. 
2x B&K 2635 Charge Amplifier. 
1x B&K 4393 Accelerometer. 
1x  B&K 8202 Hammer 

 

Template Set-Up 

1. Follow the steps 1-11 in “Time Signal and Spectrum Analysis” to set up two 
signals: 

• 8202 Hammer and 2635 Pre Amp in channel 1. 

• 4393 Accelerometer and 2635 Preamp in channel 2. 
 

 
 

2. Activate the Template 
 

3. Set up two signal groups in the Measurement Organiser and insert the signals 
as shown in steps 14 – 18 in “Time Signal and Spectrum Analysis” 

 
4. Insert the FFT into Setup in the Measurement Organiser tree and then insert 

both groups into this, see steps 19 & 20 of the previous section. 
 
5. Activate the Template 

 
 
 
 
 

 
It is possible to substitute another type of 
Charge Amplifier and/or accelerometer if 
these are not available. 
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The measurement organiser should now look like this. 
 

 
 

 
6. Right click on the hammer signal in the measurement organiser and select 

properties. Choose the Channel tab and change the Gain Adjust to –1. This 
allows for the negative signal from the hammer. 
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7. To set up the trigger right click Setup and left click on properties. Choose the 

trigger tab if it isn’t automatically chosen. Click the new trigger button and 
insert a name, in this case hammer has been used. Change the trigger type to 
signal. 

 

 
 

 
8. Chose the type of signal to trigger from, in this case the hammer. 
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9. Click on graphical setup. Click on start and tap the beam with the hammer as 
if you were performing a measurement. 

 

 
 

10. The impact of the hammer should be seen clearly. Set the Level and the 
Hysteresis lines to an appropriate amount (usually 10 - 20% for the Level, and 
5% for the Hysteresis). This can always be changed later if the hammer is 
triggering too early or not at all. Also set the delay to -0.5s. Refer to sections 
28 – 29 of “Setting up the Template in Labshop” for more information.  

 
11. Click ok and close the Setup box.  

 
12. Right click FFT Analyser and select properties. The analysis that will be used 

here will only look at frequencies up to 1.6 kHz. Set the frequency span to 1.6 
kHz and also select 1600 lines so that the measurement resolution will be 1 
Hz. 
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13. For this example three measurements will be taken and the results all will be 

averaged, to do this insert 3 for the number of averages. Change the averaging 
mode to linear. 

 
14. Click the trigger tab. Set the Start Trigger to Hammer, Record Trigger to 

Hammer and Average Trigger to New Record.  
 

 
 

15. Click on the Spectra tab and chose the hammer group under cross spectrum. 
Click the measured button. This allows the frequency response function to be 
measured and displayed. The window should look like the picture below. 
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16. Under Setup and FFT Analyser in the measurement organiser tree, right click 
the Hammer Group and chose properties. Change the Time Weighting 
Window to Transient, the shift time to 480ms and the length to 50ms. The 
shift time describes the time until the window starts, the length sets how long 
the window will be. 

 

 
 

17. Now open the properties of the Accelerometer Group. Change the time 
Weighting Window to Exponential, the Shift to 480ms and Tau to 100ms. Tau 
describes the rate at which the exponential curve decays (the smaller it is the 
faster it decays). 

 

 
 

18. Activate the template and move to the function organiser. 
 

19. Right click function group and select insert. This will add a function called 
Autospectrum (Hammer). Right click it and go to properties. 
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20. Change function to Frequency Response H1. Set the Signal as Accelerometer 
and the Reference Signal as Hammer. 

 

 
 

21. Similarly add a new function and change the function to Coherence.  
 

 
 

22. Right click on both functions and chose Show As, Classic Display. 
 

23. Follow steps 38 - 46 in “Time Signal and Spectrum Analysis” to create two 
tasks in the task bar, one to show the configuration and the other to show the 
two displays that have just been created.  

 
24. The display layout should look like this.  
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25. In the view tool bar select toolbars and measurement bar. This will provide 

you with buttons to start and stop the measurement. Make sure to save this in 
the display layout. 

 
26. Now the time weighting functions need to be set. Move to the Configuration 

window. Under the Function Organiser create 4 new function groups: 

• Time (Accelerometer) 

• Time (Hammer) 

• Time Weighting (Accelerometer) 

• Time Weighting (Hammer) 
 

27. Add the 4 groups, right click on each and select properties.  
 

 
 

28. Select the appropriate function and signal for each.  
 

29. For the two Time Weighted functions select the time weight tab and chose Use 
Signal Weighting.  

 
30. Close the box and activate the template. 

 
31. Create classic displays for the first two Time Functions.  
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32. Create a new task in the task bar called Time Weighting and arrange similarly 
to the display task already created, showing the displays of Time 
(Accelerometer) and Time (Hammer).  

 

 
 

33. Activate the template. 
 

34. Click the run button and tap the beam with the hammer. Click the Stop button. 
The time signals should show up like this. The graphs may need to be scaled, 
if so right click on the graph and select properties. Under the Y Axis tab click 
Autoscale. Alternately the use of the shortcut keys F10, Ctrl+F10 or Alt+F10 
with different Autoscale options. 
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35. Right click on each graph and select properties. Under the function tab select 
Time Weighting (Accelerometer) for the first graph and Time Weighting 
(Hammer) for the second. The two properties boxes should look like this.  

 

 
 

36. This will allow the time weighting function to be viewed over the time signal 
it will be weighting, allowing the weighting function to be adjusted to fit 
correctly. Notice that the zero value for each are not lined up. To change this 
click on the Y Axis tab and change the minimum value to –1. Use the graphs 
to tune the Shift and Length values of the transient window and the Shift and 
Tau values for the exponential window. The transient window should cover 
the length of the force impulse. The exponential window should start just 
before the accelerometer signal and decay to zero before the end of the time 
record to avoid overlap error. 
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A measurement can now be taken. 
 

37. Click on the Display tab and activate the template. Click on the start button.  
 

38. Take three successive measurements; making sure the beam has stopped 
vibrating before the next measurement is taken and that the hammer strikes the 
same spot each time. The proceeding of the measurement is displayed on the 
right side of the curve where the number of averages increases. 

 

 
 

 
The FRF and Coherence displays should look something like this.  

 

 
 

39. The coherence is a measure of how similar each of the averages are and it can 
be used as a check to see whether the measurement is good or bad. At each of 
the resonances the coherence should be 1 as this is where the signal is the 
strongest. However at the anti-resonances it is expected that the coherence will 
drop as the signal is now not as strong and is being significantly influenced by 
noise in the system. 
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40. Now for example it may be important to zoom in on the resonance at 275 Hz 
and look at it with a greater resolution. To do this right click on the FFT 
Analyser in the Measurement Organiser and select properties. Change the 
analysis mode to Zoom and change the centre frequency to 275 Hz. Change 
the number of lines to 800 and change the span to 200 Hz. This has increased 
to resolution to 4 lines per Hz.  

 

 
 

41. Notice how good the coherence has become; there isn’t a drop now at the anti-
resonance at 215 Hz. 

 
 

42. Sometimes after pressing the ‘Start’ button, it stops automatically after few 
seconds, in this case press the ‘Proceed’ button to carrying on measuring. 
To avoid this the trigger can be reactivated in the ‘Setup’ as shown before 
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Setting up a new transducer 

 
 
Setting up a new transducer under Pulse can be a useful task. While many B&K 
products are already in the Transducer database, many non-B&K products are not. 
The transducer database does not also readily support combining instruments, such as 
a 2635 Charge Amplifier and an accelerometer, which is still in use in many 
laboratories. By using adding these new combinations to the transducer database, it is 
easy to use any combination of transducers with Pulse. 
In this example an entry will be made for a 4394 Accelerometer connected to Pulse 
via a 2635 Charge Amplifier. 
 
 

1. The first step in adding a new equipment setup to the Pulse Transducer 
database is to select 'Configuration' → 'Transducer Database'. 

 

 
 

2. This will open the 'Database Administrator' window. Select 'Edit/Add' to add a 
new transducer setup. 
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3. This will open the 'Edit / Add Transducer Type'. Select 'Accelerometer' from 
the 'Family' drop-down list. 

 

 
 

4. Type a name into the 'Type' edit box. In this case '4393+2635'. 
 

 
 

5. Enter a 'Nom. Sensitivity' and 'Sensitivity Unit' for this combination. When a 
2635 is used, the sensitivity can be set using the dials on the front of the unit. 
In this case select a 'Nom. Sensitivity' of 10 and a 'Sensitivity' of 'mV/ms^-2'. 
The weight of the accelerometer can be found on the calibration sheet 
provided with all accelerometers. In this case a 4393 Accelerometer weighs 
2.4g. A description can be added if desired. 
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Note: The sensitivity setting on the 2635 Charge Amplifier should be as 
shown in the picture below. The 'Transducer Sensitivity' is taken from the 
accelerometers calibration data sheet, given in pC/m/s2. In case of the Hammer 
the sensitivity is given in pC/N and this value has to be reported without any 
changing. The red LED indicates the decimal point and is adjusted with the 
'Transducer Sensitivity' switch. The Charge Amplifier sensitivity or the 
sensitivity as seen by the analyser that the charge amplifier is connected to is 
changed by altering the 'mV/Unit Out' dial. A default value of 10 mV/Unit is 
already set in the pulse for the accelerometers and hammer used. In case that 
the overload LED is activated, this values has to be lowered and consequently 
the set up value has to be changed as shown in point. 5 above. Generally a 
high value of the output is desirable to maximize the Signal/Noise ratio. The 
high and low pass filters are set using the lower two dials. The output can also 
be integrated with respect to time to provide a velocity or displacement signal, 
though it should be noted that some error can be introduced by integrating the 
signal as any noise in the signal is also integrated and can cause the signal to 
drift from a zero mean level. Set the High Pass Frequecny filter to m/s2 and 
value of 2 Hz 
 

 
 

 
 
 
 
 
 
 
 
 

TRANSDUCER 
SENSITYITY DIAL 

TRANSDUCER 
SENSITYITY SWITCH 

HIGH PASS 
FREQUENCY FILTER 
AND INTEGRATION 
SELECTION DIAL 

LOW PASS FREQUENCY 
FILTER DIAL 

OUTPUT SENSITIVITY 



Setting up a new transducer 
Page 40 of 57 

 
For the Hammer Type 8202 

 

 
 
For the Accelerometer Type 4393 
 

 
 
 
 
 

 
6. Click 'Ok' to apply the changes. Note that Remove can be used to remove a 

transducer from the Transducer Database. Also click the 'Close' button in the 
top right hand corner of the 'Database Administrator' window. 
The transducer is now setup and ready to use in a template. 
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Exporting measurements 

 
Once measurements are taken, post-processing or storing of the information outside of 
the Pulse Labshop file is often needed. Pulse allows measurement data to be saved in 
various locations and with different file formats. How and what method should be 
used is obviously dependant on the final use. Two examples of note which may 
determine how you export the data are: modal analysis where another software system 
will be used for processing of the measurement data such as MEScope. In this 
instance it is advantageous to use the bulk save and file format given by Pulse in the 
configuration window. The other notable time is when you would like to output data 
in the same units as displayed on the graphical output. Individual measurements can 
be saved like this through right clicking the graph and “save as”. 
However the most common post-processing of data occurs with the use of matlab. 
Exporting data in a manner able to be easily accessed in matlab will be explained in 
the following section. 
 

Adding a measurement Mark 

If multiple batches of measurements are to be taken with the same setup, then they 
can all be saved in the same Pulse Labshop project file. The save measurements can 
later be reviewed or exported separately by the use of measurement marks. 

1. To save a current measurement, go to the Measurement Organiser and right 
click the “input” measurement and save. 

 
2. Now you can add a measurement mark to the saved measurement by right 

clicking and selecting “Add/Remove Measurement Mark” from the menu. In 
this case we will add “Mark 1”. 
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3. The saved measurements can now be made available for viewing or export by 
allowing the Function Organiser to follow the measurement mark. (By default 
the Function Organiser follows the current measurement in progress, being 
“Input”). 

 
 

4. Right click the “Function Group” and select Properties. 

 
 

5. Select “Mark 1” from the drop down menu  

 
 

6. You will now notice that the Function Organiser follows measurement mark 
“Mark 1”  
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Export to Matlab (fast way for small data) 

 
A simple way of exporting data is to right click on a curve already plotted, Save 
Active Curve. This command will save in a .txt file 

 
 
once saved the file can be easily edited, cutting the information up and down the file 
so that it can be used straight away in Matlab. The file will have 4 columns with the 
following data: 

Order number X axis value Y value (real part) Y value (complex part) 
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Export to matlab (recommended method) 

 
Exporting data to matlab can be done in various ways. A method for exporting when 
the data is to be processed on a computer which you are not running the Pulse 
Labshop software from is discussed in this section. This is the recommended method 
to use for exporting to matlab as it works irrespective of the software installed on the 
computer used for further analysis. See the next section for a slightly different and 
easier method when using matlab on the same computer as the Pulse Labshop 
software is running. 
 
 
 

1. Open the component organiser, as shown or with the shortcut key Ctrl+9 

 
 

2. Now select the bridge to matlab option from the component organiser 
3.  
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4. Upon selecting the bridge to matlab option a window should open as shown. 
The measured signals arranged into function groups are shown on the left hand 
side. Any combination of measured signals may be exported by selecting the 
check boxes, however here we will export all the signals being the 
autospectrum(acc) and time(acc). 

 
5. After the desired signals for export are selected a folder to which they will be 

exported to needs to be given, in this case a folder called “test” was added to 
the C:\ directory to which we will export our measured signals, also the radio 
button “do nothing” is selected. 

 
6. Once these selections have been made, click the export button. 
7. Now it can be seen that our folder C:\test, contains two new files, one a text 

file containing our measured data, and the other a matlab m-file. There is only 
ever one m-file with the name “BKFiles.m”, but depending on the 
combination of signals being exported the number and name of the text files 
may change, but this will not be a problem as the same steps can be followed 
in either case. 
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8. Now transfer the folder C:\test to the computer you wish to undertake the 
matlab post-processing in and open matlab 

9. Once matlab is open, make the copied test folder as the matlab working 
directory 

 
 
 
 
 

10. As we are assuming that the signals will be analysed on a different computer 
to the one which has the Pulse software installed, one more step needs to be 
followed. Open a new m-file in the current working directory, in this case 
C:\test. 
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11. Copy the contents of Appendix B, into the created m-file called and save as 
“GetPulseAsciiFile”. This file serves in-place of the GetPulseAsciiFile.dll file 
which is only available when the Pulse Labshop software is installed. 

 
 

12. In the matlab command window type “BKFiles”, the workspace will now 
contain three different files. The measurement data is located in the structural 
array file type 

 
 
 
 

13. Now if you are familiar with structural array file types in matlab you will be 
able to interrogate and find all the measured data information within this file. 
However if you are not familiar with structural arrays and wish to obtain the 
measurement data in a more familiar format containing only numerical values, 
copy and paste the matlab script in Appendix A, into the matlab command 
window and press enter. 

 
 
 
 
 
 
 
 



Exporting measurements 
Page 48 of 57 

 
14. Three new files will appear in the matlab workspace, being name$, data$ and 

x_axis$ with the $ ranging from 1 through to the number of measurement 
signals that were exported, in this case 2. The file named name$ is the name of 
the measurement signal in Pulse, data$ contains the measured data values and 
x_axis$ contains the x-axis range of the corresponding data$. 

15.  
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Exporting to matlab on the same computer as Pulse is running 

 
1. Follow steps 1-3 from the following section 
2. Select the “import data into matlab” radio button and the file folder to be 

exported to, being in this instance C:\test and click export 

 
 
 
 

3. The matlab command window will now be open, although it looks like nothing 
has happened the data will now be in the matlab workspace. Type the 
command “desktop” into the maltab command window to view the matlab 
working environment in the default configuration, displaying command 
window and workspace etc. 

 
 

4. Now follow steps 12 and 13 from the previous section. 
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Time Capture Analysis 

 
If further signal processing of measured signals is needed outside of the Pulse 
Labshop environment, then the raw time record data will usually need to be captured 
and exported. Outlined within this section is how to set-up the “Time Capture 
Analyzer”. 

1. Right click “setup” in the Measurement Organiser and insert the “Time 
Capture” module.  

 
 
 
 
 
 
 
 
 
 

2. Now right click the “Time Capture Analyzer” and insert the signal groups you 
would like to measure.  
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3. Right click “Time Capture Analyzer” and select properties. The time capture 
set-up menu will now be visible. From this menu; the frequency span, track 
length and trigger conditions can be selected. We will select the max 
frequency span for this analyzer, 25.6kHz and a record length of 1 s. (If the 
combination of frequency span and track length is too large for the RAM size 
on the computer that is being used, the time record can be written directly to 
the hard drive. This method is not currently explained in this document) 

 
 
 

4. Now move to the Function Organiser and right click the “Function Group” and 
click Insert.  
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5. Right click and select the properties of the inserted signal, and change the 
Analyzer to “Time Capture Analyzer” and the function to “Compressed Time” 
in the available menu. (At the moment only the compressed time is in the 
function organiser, the compressed time displays less data points and should 
be the function used when viewing the time captured data, however the 
expanded time sub-function will need to be inserted so that the full time 
capture data is available for exporting)  

 
6. Right click the inserted compressed time function and now insert a “Sub 

Function”  

 
7. Once again right click the inserted compressed time function and select 

properties, the properties menu will now have another tab labelled “Expand” 
select this tab and de-select 2^n-width radio button, and set the “Width” to the 
same time amount as entered in step 3. 

 
8. The time captured data is now able to be displayed or exported as has been 

done with other Functions previously. (Don’t forget to press “F2” to update 
the project file). 
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Why is the time record 2.56 times longer than the selected 
frequency span? 

 
When exporting time capture data you will notice that the record length is 2.56 times 
the frequency span that was selected for the analyzer. For instance if a frequency span 
of 25.6kHz, 1 second track length is selected, then the length of time record might be 
expected to be 25600 samples in length however it will be noticed that it is indeed 
65536 samples long, i.e. 1 second of data sampled at 65.536kHz. The time signal is 
actually sampled at 2.56 times the frequency span selected, in order to allow for the 
anti-aliasing filter signal distortion and comply with the sampling theorem. Therefore 
the selected frequency span indicates the useful frequency range of the data, and if 
exported for later processing it needs to be kept in mind the sampling frequency is 
2.56 times that of the frequency span. 

Where to find more information 

• Pulse demonstration videos, 
http://www.bksv.com/Products/PULSEAnalyzerPlatform/PULSEDem
onstrationVideos.aspx (a nice feature shown in one video is the ability 
to have live measurements displayed in excel.) 
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Appendix A:  

 
for i = 1:length(BKFilenames)/2; 
a = struct2array(eval(char(BKFilenames(i*2)))); 
if length(a)<2; 
    n = a.('Name'); 
    eval(['name' num2str(i) '=n;']); 
    b = a.('DatasetSection'); 
    c1 = b.('Data')(1:end); 
    c2 = b.('X_axis')(1:end); 
    eval(['data' num2str(i) '=c1;']); 
    eval(['x_axis' num2str(i) '=c2;']); 
else 
    for j = 1:length(a); 
        n = a(j).('Name'); 
        eval(['name' num2str(j) '=n;']); 
        b = a(j).('DatasetSection'); 
        c1 = b.('Data')(1:end); 
        c2 = b.('X_axis')(1:end); 
        eval(['data' num2str(j) '=c1;']); 
        eval(['x_axis' num2str(j) '=c2;']); 
    end 
end 
end 
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Appendix B: GetPulseAsciiFile.m 
 
function kk = GetPulseAsciiFile(BKFilenames1)% function input is the 

file name 
for i = length(BKFilenames1):-1:1 % loop through and remove any 

leading file directories from the file name 
if BKFilenames1(i) == '\' 
break 
end 
BKFilenames(i) = BKFilenames1(i); 
end 
BKFilenames = nonzeros(BKFilenames)'; 
fid = fopen(BKFilenames,'rt');% open file 
line = fgetl(fid);% get first line of file 
d3 =  sscanf(line, '%s');% print lines of file to d3 variable 
while isempty(d3) % loop through until a line with text is found 
      line = fgetl(fid); 
      d3 =  sscanf(line, '%s'); 
end 
z3 = 0; 
while line ~= -1;% loop through until final line of file ie. line=-1 
    clear d3; 
    d3 =  sscanf(line, '%s');% print non empty elements to d3 

variable 
    c = str2double(d3(end-1:end)); % grab header line number from 

first line of header section in file 
    d1 = d3; 
    for j = 2:length(d1); 
        field(j-1) = d1(j-1); 
        if field(j-1) == '-'; 
            field(j-1) ='_'; 
        end 
        if d1(j) == ':'; 
            break 
        end 
    end 
    value = d1(j+1:end); 
    Attributes.(eval('field')) = value; 
    ii = 0; 
    for i = 1:c-1 
        line = fgetl(fid); 
        clear d3; 
        d3 =  sscanf(line, '%s');% print non empty elements to d3 

variable 
        if ~isempty(d3) 
        for j = 2:length(d3); 
            field(j-1) = d3(j-1); 
            if field(j-1) == '-'; 
               field(j-1) ='_'; 
            end 
            if d3(j) == ':'; 
            break 
            end 
        end 
        value = d3(j+1:end); 
        if length(field) == 10; 
            if field == 'X_Axissize'; 
                s1 = str2double(value); 
            end 
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        end 
        if length(field) == 5; 
            if field == 'Title'; 
                y3.Name = value; 
            end 
        end 
       Attributes.(eval('field')) = value; 
       clear field; 
       clear value; 
        end 
    end 
    data = []; 
    z = 0; 
    while isempty(data)||(nxtindex==1) 
        z = z+1; 
        line = fgetl(fid); 
        f1 = sscanf(line, '%f'); 
        f = sscanf(line, '%s');% print non empty elements to f 

variable; 
        if isempty(f1) 
            if ~isempty(f) 
                for j = 2:length(f); 
                    field(j-1) = f(j-1); 
                    if field(j-1) == '-'; 
                       field(j-1) ='_'; 
                    end 
                    if f(j) == ':'; 
                       break 
                    end 
                end 
            value = f(j+1:end); 
            DatasetSection.(eval('field')) = value; 
            clear field; 
            clear value; 
            end 
        end 
        [data, ncols, errmsg, nxtindex] = sscanf(line, '%f'); 
    end 
    data = [data; fscanf(fid, '%f')]; 
    line = fgetl(fid); 
    z1 = 0; 
    TagScale1 = []; 
    if line(1:9) == 'Tagsbegin'; 
         for i = 1:length(line); 
            field(i) = line(i); 
            if line(i) == ':'; 
            break 
            end 
         end 
        while isempty(TagScale1) 
            z1 = z1+1; 
            f = cellstr(line); 
            line = fgetl(fid); 
            if length(line)>14; 
                if line(1:14) == 'TagScalesBegin'; 
                    TagScale1 = line; 
                end 
            end 
        end 
    end 
    z2 = 0; 
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    k = []; 
    while isempty(k) 
        z2 = z2+1; 
        f = cellstr(line); 
        m(z2,:) = f; 
        line = fgetl(fid); 
        if line(1:12) == 'TagScalesEnd'; 
                k = line; 
        end 
    end 
    m(z2+1,:) = cellstr(k); 
    SpecialSection = m; 
    line = fgetl(fid); 
    eval('data = reshape(data, ncols, length(data)/ncols)'';', ''); 
    DatasetSection.Data = data; 
    while isempty(line) 
        line = fgetl(fid); 
    end 
    z3 = z3+1; 
    y3.Attributes = Attributes; 
    y3.DatasetSection = DatasetSection; 
    y3.SpecialSection = SpecialSection; 
    eval(['Function', num2str(z3), '=y3;']); 
end 
for i = 1:z3; 
    kk.(['Function' num2str(i)]) = eval(['Function' num2str(i)]); 
end 
fclose(fid); 
end 

 


